現象
MacをLaserPecker LX2にUSBで接続すると、インターネットに接続できなくなる場合があります。
この問題は、すべてのmacOS環境で発生するわけではありません。LX2をUSBで接続してもインターネット接続に問題がない場合は、特別な操作は不要です。
発生原因
LX2をUSBで接続すると、macOSによりRNDIS/イーサネットのネットワークデバイスとして認識されます。
その結果、macOSがWi-Fi接続よりもこのUSBネットワーク接続を優先する場合があり、インターネット接続が一時的に切断されることがあります。
対処方法
インターネット接続を復旧するには、ネットワークサービスの優先順位を変更し、Wi-Fiが常にUSB接続よりも優先されるように設定します。
1. ネットワーク設定を開く
- 画面左上のAppleメニューをクリックします。
- システム設定 → ネットワーク を選択します。
- macOS Monterey以前の場合:システム環境設定 → ネットワーク
- または Command + Space キーを押して「ネットワーク」と検索します。
2. サービス順序の設定を開く
「ネットワーク」画面で以下の操作を行います:
- macOS Ventura以降:右下のその他アイコン(…)をクリック
- macOS Monterey以前:左下の歯車アイコン(⚙️)をクリック
- サービス順序を設定… を選択
ネットワークサービスの一覧が表示されます。
3. ネットワークサービスの順序を変更する
- Wi-Fi をリストの最上位に移動します。
- RNDIS / Ethernet(LX2のUSB接続) をWi-Fiの下に移動します。
- OK をクリックして設定を保存します。
4. 設定を適用する
- macOS Monterey以前では、適用 をクリックします。
- 確認メッセージが表示された場合は、そのまま変更を確定します。
設定後はWi-Fiが優先されるようになり、LX2をUSBで接続したままでもインターネットに正常に接続できるようになります。